Caller ID

Joe33472
Novice II

Just wondering how to get your name to show up on caller ID for people that you're calling.   When I call my family and friends' home phones my call shows up as "WIRELESS CALLER".  

9 REPLIES 9

bpositive
Intermediate III

It looks like you have enabled Hide my caller ID. To disable this, go to call setting and enable show my caller ID.

When I click on "Show my Caller ID", nothing happens, there is just a spinning wheel? 

Where? settings where? Visible account settings? profile?

 

I think they meant in your phone settings to enable your caller ID

Sorry, I never figured out the solution and my name is still showing up as "Wireless Caller".  

visiblepanda
Novice III

where in settings? visible account? or my device call settings?

Joe33472
Novice II

UPDATE:  Despite having put in a ticket with Visible support, I'm still showing up as "WIRELESS CALLER" on caller ID.  But here is the strange thing, I popped in a physical Red Pocket sim, and the option to show caller ID worked on my iPhone.  Now I'm wondering if it's an esim issue.  

 

 

rDeborah
Novice

I'm having the same issue with the esim on my iPhone. When I go into settings and Caller ID, nothing comes up, no option to turn it on or off, just a searching icon. Any advice on how to fix this?

Lombie
Novice

For me, the name of the party who previously owned the number was showing up. 

 

I submitted a ticket to Visible asking for it to be changed to my name and about 12 hours later received an email from Visible indicating the change had been successfully completed.  However, they changed it to "Wireless Caller," not my name as the initial chat agent had said he'd submit. 

 

I just contacted chat again and was told that Visible doesn't offer "premium Caller ID services."  The only options are either "Wireless Caller" or your 10-digit phone number. 

 

Crummy. 

 

Visible assigned my number.  Seems they should be able to label the Caller ID, too.  If I'm not in someone's contacts so my name pops up, they don't take my calls!