Number port in option not displayed while trying to activate a new phone

visibleuser1
Novice

Got a new iphone and trying to port in my number. But not seeing option to port in while trying to activate account

7 REPLIES 7

joshblack777
Novice

gpjstn
Novice

I had this same issue. Here's exactly what I did, hopefully this will work for you too.

 

1. Activate the phone using the "temporary" number that comes with the new line (support will ask you to do this)

2. Reach out to support using the app - the wait time is extremely long right now, but with enough patience, you will get connected to someone eventually. Try to keep the session active so that it doesn't time out - I did this by minimizing and maximizing the chat window every few minutes.

3. Once you get connected, they can port over the number very quickly. Be sure to have your previous carrier's account number and port-out PIN number.

4. After a few minutes (in my case) I got an email and a notification from the app that the port was complete. It did take a few minutes after those notifications for the service to fully activate. But from the time of porting to full activation, it was only like 15 - 20 minutes.

 

Hopefully this works for you all, this seems to be a widespread issue πŸ™

Yep. I didn't realize I had to complete the setup with the new number on the new phone after I had created the new number on the phone purchase. The use existing number option displays after you set up your new phone with your new number. Like you suggested.

visibleuser1
Novice

Thank you!! Followed above steps and ported my old number.

rveturi
Novice

I am having the same issue, hoping to resolve it with the steps provided by @gpjstn . Let's see how it goes.

rveturi
Novice

I am having the same issue, hoping to resolve it with the steps provided by @gpjstn. Let's see how it goes.

rveturi
Novice

Exactly as @gpjstn mentioned, apart from the wait time, everything went smoothly.