Visual Voicemail won't open and not getting vm notifications

Novice II

I recently upgraded to the new $30 plan w/$5 monthly discount. Was having issues with voicemails showing up late and not getting notified that I had a vm before the upgrade. Then the voicemail app stopped opening altogether. This fixed it for me:


Go to Settings - Apps - Voicemail - Storage - Clear Data


Then Open Voice Mail and go through the prompts .



This works for me but only temporarily.  As soon as I get another VM, I am right back where I started.  No notifications and can only open VM by using *86.  Every time I have a missed call, I am now calling into VM to see if there is a message.  Very annoying.

Having same problem. Is your phone a S21 Galaxy? 


I recently got an unlocked S20 and it didn't come with a VM app so I downloaded an app called "youmail" and it's been working well. It forwards your voicemail to their service and then you get a notification that you have a message and you can see and listen to the message within the app.


Will clearing data cause me to loose my Contacts?  I tried clearing Cache , that did not work.  Just don't want to loose all my contacts.