Pixel 4A (5G) having trouble sending MMS

jnelsoninjax
Novice II

I know that this issue is not carrier related because it was happening when I was with Xfinity Mobile, but this is getting really tiring. When I try to send some people MMS messages they never get them, I am using Textra as my messaging app and it tells me that the message was not sent. I have tried using the default messaging app and the issues occur. Short of resetting the phone to default, nothing I have tried seems to work. I have double-checked the APN is set correctly, I have tried it on and off of WiFi with no difference. Has anyone else had similar issues like this with Pixel devices? The thing that makes it even odder is that I can send the same MMS to my niece, who is on T-Mobile, and she gets the picture without issue, but the other people whom I normally send to are on Metro PCS and Xfinity Mobile, and the one on Xfinity Mobile has the same phone as I do.

Just to clarify the steps I have taken: I have reset the network settings, power cycled the phone after network reset, tried the default messaging app, and verified that the APN is set correctly and that there is only one APN.The only thing I have not done yet is do a factory reset on the device.

Now if this issue isn't odd enough, figure this one out: for some reason all through the day the MMS fails to send, but as soon as it hits 23:00 (11 PM) suddenly they all work with zero issues...

 

1 ACCEPTED SOLUTION

TheCellTower
Novice III

Sending MMS with the pixel on the Verizon network is a known issue and usually there's  Nothing what to do about it you could try to resend it a few times until it goes,  Usually after a few tries it  Works, Also this issue was only on the Verizon network on any GSM network should work if it doesn't work means that you have to fix the APN settings, Another thing what's gonna solve the problem is to download the Verizon Messaging app that works even over Wi-Fi but the SIM card has to be in the phone so you're gonna be able to send the MMS over Wi-Fi or even over data

View solution in original post

4 REPLIES 4

TheCellTower
Novice III

Sending MMS with the pixel on the Verizon network is a known issue and usually there's  Nothing what to do about it you could try to resend it a few times until it goes,  Usually after a few tries it  Works, Also this issue was only on the Verizon network on any GSM network should work if it doesn't work means that you have to fix the APN settings, Another thing what's gonna solve the problem is to download the Verizon Messaging app that works even over Wi-Fi but the SIM card has to be in the phone so you're gonna be able to send the MMS over Wi-Fi or even over data

OK, that explains why I was having the issue with Xfinity Mobile as well since they use the Verizon network. I will try the Verizon messaging app. Thanks for the suggestion.

ETA: I downloaded Verizon Message App and set it as the default messaging app, but it caused the phone to freeze up and when it wasn't frozen, it simply showed the MMS as qued, I had to reboot the phone and remove the app because it was doing something really strange. Have you heard of or had similar issues with the app?

No I never had it. the thing is it's a heavy app you could try downloading again and set it up slowly I don't remember having problems with massage plus all my friends are using it 

wcshort22
Novice II

Everyone do yourself a favor and switch from Visible right now if you do not have MMS messaging. This is the sorriest excuse for a phone company I have ever experienced. I signed up for their service 8 days ago and originally had no service whatsoever. After doing my own research, I was able to get talk, text, and data, but no MMS messaging. After 8 days they still could not figure out the issue. I have probably wasted 18 hours of my own time trying to get this fixed. I've submitted probably a dozen tickets. Their customer service is completely incompetent. The only way to contact them is through their online chat and all they can do is submit a ticket. Every time you submit a ticket, it takes 24 to 48 hours for someone to get back to you. When they get back to you, it is a one-sided email that you cannot respond to. They tell you everything is fixed and you just need to reboot your phone and it should work. That was a lie every single time. When I would chat back in, I would go right to the end of the line and have to wait another 24 to 48 hours. After 8 days of doing this, I finally forced one of their online chat agents to stay connected to me until someone called me back. This was after 3 days after putting in a call request and not hearing back from anyone. Someone finally called me back and said they would submit another ticket. Shocker. Someone called me back later in the day and said that my phone was incompatible with the network. It was their own website that told me that my phone was compatible. He said that sometimes that their compatibility checker is wrong and my phone should be compatible "soon". He then had the audacity to tell me that they were not going to refund my money from where I signed up for service. I have never experienced worse customer service in my entire life. Do yourself a favor and leave this company and never turn back. I have a Galaxy Fold 3 btw.