Pointers on getting Mobile Data to work on a new Samsung A13


I just ported my number over from a Verizon Business account yesterday and everything seems to work fine except I cannot connect to a mobile data network.  I have tried all of their troubleshooting ideas and spent over 1hr chatting with customer care this morning only to be told I would receive an email when the issue was resolved.  That was 4hrs ago.


I didn't think it would be that big of a deal since I have WIFI just about everywhere, but I'm still using the phone for work and I just learned group messages and picture messages will not download or send without data  (or maybe I have more problems).  Unfortunately I use both of those at my work.  If the situation is not resolved shortly, I'll have to do something different.  


Here are my exact settings that fixed my MMS messaging issue for the Galaxy s20FE.




I shared this link because adding photos on this site is awful.  I hope this helps others.

View solution in original post


Your APN settings has to be adjusted

Add this APN 

Name: Visible


APN: vzwinternet


MMSC: http://mms.vtext.com/servlets/mms


MMS Port: 80


MCC: 311


MNC: 480


APN type: default,dun,supl


APN protocol: IPv4/IPv6


APN roaming protocol: IPv4/IPv6


Make sure to save it and restart the phone this should fix the problem but I won't fix the problem for MMS

Thanks TheCellTower! After doing this over and over and over, it finally worked for me.
The only thing I see different from the settings listed above is that I didn't need to put in port 80 on the Visible APN, and on the Visible APN I did have these added under bearer setting: HSPA,GPRS,EDGE,eHRPD,UMTS,LTE,HSPAP,IWLAN,HSDPA,NR, and HSUPA.


Go figure! I am not sure what made it work.


One other thing to note: I had 5G on my Galaxy s20FE before the upgrade to the $30 plan and now all I see is LTE and LTE+.




Thanks again TheCellTower!

You welcome!!!!!😀 I'm glad I was able to help!!!!!

You could get group messaging and picture messaging over Wi-Fi with the Verizon messaging app

I downloaded this but it still won't send or receive picture messages.  Thanks for trying to help though!

As I s

As I said in the beginning that it will probably not help, the reason why you don't have picture text is because the APN settings has to modified sometimes every device needs different settings, if the sopport would know what APN settings they would be able to help, but they don't even know what APN settings mean!!!!!!

Visible doesn't even have the APN settings on the website, most companies have the APN settings on the website or the sopport could give it to you, and usually there is a few to try if one doesn't work it has to be modified. You can send and receive MMS over Wi-Fi with the Verizon messaging app (message plus). It should work 

After you add the first APN add another 2 APNs click on the plus sign to add APN


Name: Verizon CBS




MMSC: http://mms.vtext.com/servlets/mms


MCC: 311


MNC: 480


APN type: cbs,MMS


APN protocol: IPv4/IPv6


APN roaming protocol: IPv4/IPv6








Name: Verizon FOTA




MCC: 311


MNC: 480


APN type: fota


APN protocol: IPv4/IPv6


APN roaming protocol: IPv4/IPv6

This might fix the problem for MMS no greentree but make sure the first APN (visible) is selected, after adding APN remember to save it 

THANK YOU! This got my mobile data to work but still no MMS.  I spent another 2hrs chatting with support this morning and still nothing....except they had me reset my network settings so I have to enter all of this again. 



If they ever get your MMS issue resolved I would like to know.


I have been through everything to try to get my MMS messaging to work to no avail. I have been through it all.
I tried all of the APNs and while I have data none of them fix my messaging. The latest email from support said to update my phone to Android 13. That's is great and all but that will not roll out until sometime at the end of the year.  Slight frustration here to say the least.


So did you finally get your MMS working?


I did. Let me know of you need any help. 

Yes, I need help.  Please and Thank You!

So, what exactly did you do to get the MMS working?

Here are my exact settings that fixed my MMS messaging issue for the Galaxy s20FE.




I shared this link because adding photos on this site is awful.  I hope this helps others.

Which one is selected?

The one that is vzwinternet should be the one selected as default.


Don't forget to restart the phone after entering the settings.

Edited the album to show which APN needs to be the default.

Well, this is weird.  I entered your visible internet settings and my mobile data started working (I had it working before using Cell Tower's settings but yours were a little different).  Next, I entered your visible cbs APN and my MMS started working.  Should I go ahead and enter the FOTA APN?  I'm kinda scared to mess with it since it all seems to be working now?

I would go ahead and do it. I don't think it will break anything.   I am glad that has fixed your MMS.

Your amazing!!👍we so many people here trying to fix MMS where are they now let them know you figured the issue and how to resolve it.



I can't take all the credit. We all just test things until it works, so we all manage to fix what is broken. Another thing being Visible and their CS.

I just hope this bring a quick fix for people having issues with the phones they bring to Visible. The issue seems like is plagues Androids more that the iPhone. But I have had this happen when I upgraded my s8+ that worked perfectly on Visible to a Galaxy s9+, the same thing happened when I switched the sim over to the s9+ the APNs did not populate.  This is definitely a Visible issue that they are not in a hurry to fix.

This is what we get with the inexpensive cost of Visible .

Russellowens20, You are THE MAN!!! That finally fixed it!!!

I am using a eSIM on a Samsung NOTE 20 Ultra 5G on the $30 plan in case anyone else is looking for a work around. Thank You Russell Owens !


I have Note 20 Ultra 5G from Verizon that I was able to activate on $30 visible with above instructions. Everything working except I noticed WIFI calling option disappeared ( it was there with verizon sim). Can you please reply if your device does have wifi calling option or this phone not supported by visible. Maybe you know the way to activate it ?

Thank you.

My phone does not have wifi calling on it either.  I'm glad that worked for you.


These forums should have a sticky at the top that keeps important information like this at the top to ease the pain for when Visible's APNs do not auto create on phones that are compatible on their own site. Shaking my head!

Novice II

Everyone do yourself a favor and switch from Visible right now if you do not have MMS messaging. This is the sorriest excuse for a phone company I have ever experienced. I signed up for their service 8 days ago and originally had no service whatsoever. After doing my own research, I was able to get talk, text, and data, but no MMS messaging. After 8 days they still could not figure out the issue. I have probably wasted 18 hours of my own time trying to get this fixed. I've submitted probably a dozen tickets. Their customer service is completely incompetent. The only way to contact them is through their online chat and all they can do is submit a ticket. Every time you submit a ticket, it takes 24 to 48 hours for someone to get back to you. When they get back to you, it is a one-sided email that you cannot respond to. They tell you everything is fixed and you just need to reboot your phone and it should work. That was a lie every single time. When I would chat back in, I would go right to the end of the line and have to wait another 24 to 48 hours. After 8 days of doing this, I finally forced one of their online chat agents to stay connected to me until someone called me back. This was after 3 days after putting in a call request and not hearing back from anyone. Someone finally called me back and said they would submit another ticket. Shocker. Someone called me back later in the day and said that my phone was incompatible with the network. It was their own website that told me that my phone was compatible. He said that sometimes that their compatibility checker is wrong and my phone should be compatible "soon". He then had the audacity to tell me that they were not going to refund my money from where I signed up for service. I have never experienced worse customer service in my entire life. Do yourself a favor and leave this company and never turn back. I have a Galaxy Fold 3 btw.

I understand your frustration. Customer No Service is the worst with Visible. If something does not work with a compatible phone you're on your own. 


Did you try the settings I listed above? 

Yes I did. I tried a hundred different variations of APN settings and couldn't ever get MMS to work. 

I spent 4 weeks working different APN combination and finally got mine working. 


If you have not looked at my phone screen shots and tried them,  I would say it is worth a shot. 


Mine are not the same,  especially the main APN. 


Good luck!  Russ

Please try the APN settings listed above that worked for everyone, after adding the APN you have to restart your phone and send a MMS to your self or get a friend to send you a MMS, old MMS won't download after setting the APN you have to try with a MMS 

Thanks to everyone for working this problem out. I ported from Verizon, two brand new unlocked Galaxy S22+ to Visible this morning and had no data on both. I found this fix while waiting for a Visible chat response and had data working on one of the phones before the chat began. Visible customer support performed an eSim redownload but that did not fix the problem. The APNs were not populated on either phone but both are now working, with data and MMS, using the info listed here. Hopefully it sticks. As for Wi-Fi Calling, that option was not available after porting from Verizon. After adding the APNs both phones received an update which fixed the missing Wi-Fi calling. For now I will continue with Visible but if the data or Wi-Fi Calling problem comes back I'll be going back to Verizon. Thanks again for everyone's hard work on this fix.