Can text/call but no network data?

Novice II

I just signed up. Husband had has service for several months without any problems. Got calls and texts available, but can't get network data to work. I get error messages saying I'm offline. Help center says to reset network, turn off roaming, then ended up doing a factory reset. Nothing works. They said my phone just isn't connecting properly. I ordered it with my service.  Could it be a sim card issue, too? Been without my news service for 2 days now. 


What APN settings do you have right now? you can find the APN settings on your Android device by going to: Settings> Mobile networks> Access point names

If you have iOS go to: Settings > Cellular > Cellular Data Options > Cellular Network.

Try editing it to 'VZWINTERNET' than save it and make sure it's selected and restart the phone that should resolve the problem please let us know if it worked

Holy crap!! That worked. I spent 5 days and numerous hours on chat with them, to get nowhere. Your suggestion fixed my issue. Thanks!!!

You welcome I'm glad I was able to help you 

Ok, so now I have network access, but i still can't send or receive images via text/sms. Any clue what would be causing that?

Probably because you have to fill out the other things in the APN settings let me if it's possible to fill it out or it's grayed out, if you could edit the other things I'll share with you the settings 

Yes, I have the option to fill in the other settings. I would sooo appreciate the help! That's the very last piece to get settled, and I'll have fully functioning service. 

APN name: Verizon 2

APN: vzwinternet

MMS port: 80


MCC: 311

MNC: 480

Apn protocol: iPv4/iPv6

Apn roaming protocol: iPv4/iPv6

APN type: default,supl,mms


Leave all other fields blank, and save this configuration.

Restart the phone 


Tried it, but something in there knocked my connectivity out again. Adding them one at a time, to see which it is. 


I believe it was the MMSC & Apn type, so far. 

I do have data but, it has gotten painfully slow.  Changing the APN to VZWINTERNET got me to not connecting at all.  I changed it back to VSBLINTERNET and it's working again, just barely.  I've been with Visible since Dec 2019 and it has been getting progressively slower.  I'd be happy with 1 mbps most of the time but, most of the time I'm about 0.15 mbps.  Today I haven't had usable data all day. 

Are you now on party pay plan for $25 or you moved to Visible's new plans for $30 or $45. 

If you are in partypay plan these APN settings will not wok.

Just another visible user, willing to help others.
Please mark my answer as solution if it helped you.

The old network sets the APN settings by it self no need to touch it 



Wifey had the same issue with a Samsung S10e. We reset the network settings, but didn’t look at the APN. To keep the wifey happy, I’m an Apple guy, she went back to Verizon.


Novice II

I tried the apn trick and it did not work 

Make sure it's saved and selected and restart the phone