Apple Watch S6 Won't Load Cellular Activated Plan From Visible

Novice II

OK, first off, I have:


Apple Watch Series 6 (Cellular)

iPhone 13 Pro


I went through the setup process with Visible through the Apple Watch app to setup my cellular plan. My Visible account online confirms that I added "Visible Watch Service." However, the Apple Watch doesn't show up under devices online. I've tried turning the watch off and rebooting it as Visible said during setup. I've also rebooted my iPhone.


However, when going to the Apple Watch app on my iPhone to confirm cellular access, it says "loading cellular plan" for about 30 seconds, then it just fails and reverts back to the link that says "Setup cellular".


On my Apple Watch, going to Cellular says: "No Sim, No Connection." I have tried going through the setup process again only for it to fail... AGAIN.

I would appreciate any help here!!


Novice III

Ugh! That's annoying. Have you contacted Visible's customer service yet? If not, you can start a chat here. They take a while to connect through chat, but once connected they are pretty good at solving issues. That said, someone else was also having Apple Watch connection troubles, so it might be a bug that Visible needs to address. I hope they can find a solution for you.

It took cs over a month to get my aw6 to work after contacting them every other day till it was fixed


I must be the other person and it has been 3 weeks and I imagine when the answer the messenger app it will be a third or fourth case opened on it now. So aggravating when this is the reason I switched 5 lines of service.

Novice II

What was the resolution because I’m having this exact issue and it’s been over a week and they are not helpful and cannot figure it out. I keep getting bs emails saying something was tweaked on their end but nothing has been resolved.  After it says my watch has been added the app closes out and won’t load the activate page so my esim can’t activate.