"Something went wrong" error creating an account


I cannot seem to create an account. I have tried with different emails and I get the same error. Initially when I create the account, this shows up above the the first name:

"Something went wrong, we are trying to fix it."


I receive an account verification email and link. After clicking on the link, it looks like I am logged in. However when I try to order a SIM, a message flashes up: "Something went wrong"


I contacted chat, but received no resolution. They suggested trying a different email, which I did. No change. They suggested posting an image on facebook or twitter, which I am not willing to do.


I tried this with both Chrome and Edge. Same problem.

So I am posting here. Please help!



Let me get this straight, why are you uncomfortable posting a photo of your screen via Twitter DM and Facebook Messenger?


I have no advice to help you: you tried different browsers & different email addresses. You didn't say if both email addresses were yahoo.com or gmail.com addresses. If both were from the same company, I would try one Yahoo and one Gmail email address.


You could go over to Reddit, and https://www.reddit.com/r/Visible/  where a Visible employee MVNOResearch sometimes is able to help with Visible issues.

If a post has solved your problem, please mark it as an acceptable solution, it helps others that may have experienced a similar issue get a quick resolution.


I too am wondering why the hesitation to post pictures. If you are concerned about some sort of personal information, you could always blur/block just those portions of the image. Having said that (and I don;t use Facebook or Twitter), but based upon the feedback from beav above, you presumably would remain private through those methods in the first place.


If it were me, I would either follow the recommendation of Chat help or take beav's advice and use his reddit link.


Hope you can easly resolve your issues.


Got the same issue with your error message while trying to establish an account.  I have registered two phones previously with no problems.  I think they are having some computer glitch with activation.  When the reply says they are working to get it right...let's hope they are. Customer chat were going down the list...but not help.  I think it is their software problem.  Any help is appreciate



Same problem.