Visible acknowledges customer service problems

Not applicable

Finally, the first step in fixing something is acknowledging it's a problem. May we all see better days ahead.


Intermediate II

Good read, but saying customer care is available 24/7 is a bit misleading 😂. I haven’t been able to actually get a person since Thursday. 😂

Best advice that I found on here and that worked for me was using an actual computer and starting the chat. To prevent timing out, just keep clicking your name and account in the drop down menu. It took about an hour to get through. I feel like phone based app doesn’t work at all. Also, AM hours if you could, first time I got through was 7AM Monday, second was 9AM today. GOOD LUCK!! It’s actually insane how limited the access to customer service is. ✌️

Laptop, iPad, iPhone—no luck on any of them.  I’m close to just going somewhere else.  They’ve told me that the only way to change plans is “through the app” yet they acknowledge some phones, operating systems aren’t working right.  I’ve even got a case number assigned by the rep last week who told me to reference the case number if I need to chat again.


Novice III

It seems that’s what they’ve been doing, is either escalating with a case number, or giving generic answers. So frustrating. I’ve been through these forums a ton lately and saw a bunch of customers switch over to Mint Mobile with success. 

Are you having issues with updating to the New Visible plans? If it’s a service issue, such as no service available even after Plan successfully updated, I know a few tricks that Visible gave me pre-chaos that worked for me. I’m on an iPhone 10 (XS MAX). 

I have an iPhone 11 and there is nothing in the app that will let me change plans. For a couple of days I had a button to select a plan, but it errored out “uh oh, we are unable to process your order, contact customer care to resolve.” Then the button disappeared completely.  Some on this forum had an option to change in their overview, but not me.

Novice III

So weird, for me it popped up as “explore new plans” on my welcome screen, then I clicked the $30 one, and it guided me until everything transferred. 


There was an app update today. Maybe try deleting and reinstalling? But that’s just a guess. There’s been so many glitches. Hopefully, it gets situated for you!