Apple Watch - unable to activate - Visible web page won't scroll

Novice II

I have been trying to help my wife activate her brand new Apple Watch SE Gen 2 but cannot complete the activation via the Visible website within the Watch app.  We are able to follow the prompts to do cellular activation, login to the Visible website within the Watch app.  However none of the pages served from the Visible website will scroll so we can't reach the confirmation buttons at the bottom of the pages.  I was able to trick the address confirmation page to scroll by tapping in one of the address fields but the subsequent page to confirm the charges to our card refuses to scroll.  I spent an hour on the support chat with no help.  We are completely stuck.  We've rebooted the phone, deleted the Visible app, reinstalled it, changed all of the rendering settings, font sizes etc and purged the Safari history/cache a dozen times.  Any help is appreciated.



I’m having the exact problem. Very frustrating.  


I’m having the same problem. Customer service is no help. very frustrating 


Same issue. Seems like the issue is outside the Visible app and with Safari/iOS? If no solution exists as of now, maybe we need Apple support on this?


Having the same issue. I contacted apple support and they informed me it was on visible’s end so there is nothing wrong with our phones or watches. I’ve been talking with visible support since Christmas Day but they keep pawning me off to “higher tier support” so I have to wait at least 24 hours to receive an email that tells me to the same thing that last set of support told me to do. It’s embarrassing that support can’t even look at my case to see what I’m contacting them about and instead make me explain my problem to someone new every. Single. Day. The unprofessionalism and lack of structure in this company makes me feel like it would be worth it to pay more at a company with real support.

Novice III

Same issue here!  Page won’t scroll!  Grrrr!

Novice III

Just curious, which model of iPhone do you have?  Mine is 13 Pro. I wonder if this problem is specific to particular models?

I am working on an iPhone Xs


The issue is with the UI code that displays the interface which Visible is responsible. They need to update their code. 


I just chatted with support - they have sent this over to get fixed by their back end team...  Here is a screenshot I shared with them of the issue...  Not able to scroll down to accept terms and continue.


they are supposed to reply to this thread when it is fixed.  

Thanks for the update. I was able to register my watch np then a week later i couldn’t do my wife’s. Both 14 pro +. Shouldn’t take more than 5 mins to fix, no clue on how long they’ll wait to push it out though. Fingers crossed…

Thanks for the info!  This sounds promising. Hopefully, they’ll roll out a fix soon. 😀

Just a follow up - I used the chat service again today for support - I was able to get the watch activation page to scroll up after it error out...  Eventually I was able to get my watch activated and it is working now.  For those of you still experiencing this - give it a shot again...  

Sorry but it is still not working for me. The pages refuse to scroll.  The fix has not been applied.


I'm stuck with this issue as well; 6 or 7 support calls and at least 8 hours later, no resolution -- but I do have an active support ticket that they seem to be looking at, and I've pointed Visible to this thread to make sure they're aware that this is systemic.

With any luck their dev team will just roll back the code until they fix the problem -- given that some folks have been able to set up cellular not long ago, it sounds like this is probably the result of a bug introduced during an update.


I was having the same issue.

I clicked on add payment method, then clicked on me default method again. Did this a few times until the page scrolled down and I was able to hit the activate device button!

Hope this helps!

Awesome, i will try this when i get home, thanks for the info

Unfortunately, this does not work for me. 😔 I tapped on the payment method multiple times, and even tried selecting, “choose another payment method” and going back-and-forth multiple times. I simply cannot get the screen to scroll on my iPhone 13 Pro. 


I was having this same issue!


I clicked on add payment method, then reselected my default payment, and repeated that process a few times until the page scrolled down. Very irritating.


Hope this helps!

I tried this method about 25 times with no success.


I had the same problem as others here, but found a solution: I was able to activate a watch by turning on voice control and telling my iPhone to “move down” (Settings > Accessibility > Voice Control).

I wanted to second what Jsword said: Turn on setting > accessibility > voice control. Once setup, a blue microphone icon will appear on top of phone when it is listening. Just say “scroll down” and it will take you to the bottom of the page to accept payment method. Finally… done.

Thank you.  This worked for me as well.  Brilliant workaround! I’m still frustrated that visible doesn’t seem to have any urgency fix this. Not inspiring confidence.

So I get a message from Visible asking me as the original poster to mark this response as the solution. I am not inclined to do that because this technique is a "workaround".  The issue remains that Visible needs to fix their back end code so that the HTML page scrolls like it it should.  The issue is not fixed.  Visible, please apply an actual fix on your end so that other don't have to continue to rely on a workaround.

This helped out. Thank you SO much!

I was hopeful when I came across the post. But unfortunately, this did not fix the issue on my iPhone 12 mini. My experience with Visible has been overall disappointing.

Thank you so much! This worked for me and I passed it on to the chat person. 

That worked for me. Thanks!


Thank you. Worked for me. Had 2 support calls. Support initially told me

“Oh I want to tell you one thing that you can't add a apple watch in the mid of the billing cycle Barry, this is because to keep a sync in between your device and the apple watch.”

This may be true, but I still had the iPhone watch app screen scroll issue. 
Thanks so much


This workaround worked for me.


First, you have to only have one payment method attached to your Visible account. If you have more than one, log on a separate device and remove all other payment methods except for your primary method.


Pair a Bluetooth keyboard with your iPhone. You can learn more about how to do that here:


When you get to the offending screen, click on "Add a payment method" and the use the [Tab] button on your keyboard to navigate down to the text boxes. This will show the "Activate" button. Click on your default payment method, then click "Activate" and you're good to go!


Sucks that you have to have a Bluetooth keyboard to figure this out.... But at least it worked for me {shrug}


This worked for me.  I also tried the Voice Control suggestion but it didn't work.  


I strongly agree that Visible should be reviewing frequent issues and this Community board and fix things.   To me that is not being responsible to your customers.    Visible!  Are you out there????

Outside of some moderation (via Khoros) to keep things civil, Visible doesn't actively particiapet here -  it's primarily customer to customer support.

FWIW, they do actively participate in the Visible subreddit at:

Even customer particiapation here is much lower than it used to be.

It's amazing that this was posted almost 2 years ago and this is still an issue.  Okay, so I've had the same problem of getting that "oops something went wrong" page and had been communicating with Visible about this for weeks!  I finally read on here where someone was having a something similar issue, and their support person deleted their esim and then sent them a new esim, and that resolved the issue.  I had my support person do this, and guess what, no more problems!  I am now up and running again!  I hope this helps!

It's ridiculous that this is still an issue that customer support does not know how to address.  I spent 2 weeks experiencing the same exact thing when I left visible and then came back.  So here's the fix people.  Have them delete your esim while they are on the phone w you.  Have them email you a QR code to reinstall the phone number.  You are going to also have to uninstall and reinstall the visible app and the watch app.  Make sure to unpair the watch first of course.  Why I had to research and find this answer and share it with them in order for them to help me, is beyond me.  Anyway, I hope this helps.