OnePlus 9 5G Support - Highly conflicting information


I just switched to Visible from Mint with my OnePlus 9 (LE2115,) and I'm a little frustrated.  I've searched forums and can't get a solid answer.  Most threads are almost a year old now.


I live outside of a major metro area and always had plenty of sub-6hz 5G signal from Mint (T-Mobile.) I saw several mentions of 5G-compatibility for the OP9 with Visible on the web...

And the IMEI checker said "Boom, you're good to go!" 


Unless I missed the fine print or a tricky little asterisk on that statement, I assumed that to mean that my phone was fully compatible with the network.  I knew 5G UW wasn't an option because the OP9 doesn't have that antenna... but sub-6hz 5G should be possible.  


Did Visible previously have 5G compatibility? Was it deactivated?

The compatibility checker feels highly misleading in retrospect... There should've been some kind of warning that I would be limited to 4G LTE. If the porting process wasn't such a pain in the neck, I'd be leaving Visible already.



Visible still has 5G compatibility, but they are on the Verizon network.  So the phone may be compatible but it may be that  Verizon does not have 5G or the correct 5G coverage for the phone.


Is there anyone else you know in the area on Verizon network in your area that gets the 5G coverage?

If a post has solved your problem, please mark it as an acceptable solution, it helps others that may have experienced a similar issue get a quick resolution.

I just switched to Visible directly from Verizon where I was almost always getting 5G but now on Visible 5G does not show up as an option in my settings (OnePlus 9) . I chatted with Visible service and they tried just really light troubleshooting which did not solve the issue. Which is how I found this post as I'm now searching for myself. 

I found something that did not work for me but the person that wrote it was very confident that it works (maybe they closed the access since) Here is what it said:

Go to dialer and enter *#*#4636#*#* then choose"phone information"

Under set preferred network type choose NR/LTE

Unfortunately for me nothing happens.



I don't know if this still helps, but I updated my visible plan and when the new SIM card arrived I first activated it on an iPhone 13. After that I went back to my OnePlus 9 pro and boom 5g working. Visible website says it is not compatible with the new plan.

To get the new sim, did you have to put in a random IMEI number in order to upgrade it?

The easiest way to do it is to put in thet you have a iPhone then they won't ask you for your IMEI 

Yeah but do you need to activate it first on the iPhone before you can use it on the OP9pro device?

did you have to put in a random IMEI in the visible website in order to get the new sim sent? 

Did you have to activate it on the iPhone first though before you put it in the OP9pro? I don't have another phone but I was going to try to order a new SIM saying I have a iphone 13 but then just pop it into my OnePlus 9pro. Will this work you think? Just trying to see if this is possible or not. 

Yeah I'm wondering the same thing. 

Yeah I'm wondering the same thing. I have the OnePlus 9. Not the OnePlus 9 pro.


Are you on visible right now with your phone? I am on there network but not visible plus yet since it says my phone isn't compatible with that part yet 🤦🏻

Hey, I'm on visible's network right now. It says the same thing for me. My phone isn't compatible with the plus plan.


How is the 4G LTE speeds with OnePlus 9? Why are you specific about 5G?

Just another visible user, willing to help others.
Please mark my answer as solution if it helped you.

Novice II

What are the chances if you switch to an eSIM with visible that would fix the issue?


I am thinking it might be worth trying.



I tried to the phone is not compatible with eSIM either lol. I might switch to Mint Mobile because there is no time table it seems to when OP9 pro 5g will be compatible or if it will even work well. 🤷🏻

Figures hahaha.....Well thank you for letting me know before I went and switched it over. Haha