Phone USB-C to USB-C port on Windows 11 computer does not work. USB-C to USB-A works.

Novice II

I have a 2-year-old ZTE Blade 10 Prime. It works fine if phone USB-C is connected to computer USB-A but is not recognized by the computer if plugged into the computer USB-C port. Is this normal? I tried reloading drivers but with no luck. I tried several good quality USB-C to USB-C cables with no luck. Those same cables work fine with an external hard drive to the computer.


Novice III

Hey @SUSFU, I don't quite understand, but this seems to be a laptop issue. If your laptop has an AMD APU, then the USB C port will not work. If it has a Intel CPU, then it will. This is because thunderbolt is only for Intel chips and not for AMD chips.


Hopefully I have answered your question/concern. If I have, please give me a kudo. (I am not an Employee, and this is a copy & paste msg from the LTT forums)

Novice II

You could be onto something, it is an Asus laptop with an AMD processor. You lose me on the thunderbolt stuff though. I thought thunderbolt was an iPhone thing and my phone is Android.

Sometimes it is just the cable. I know I try plugging my phone in the car. One cable, no issues, another cable, no connection recognized. I would try a different cable.

If a post has solved your problem, please mark it as an acceptable solution, it helps others that may have experienced a similar issue get a quick resolution.

I've tried several cables with the same problem. Those same cables link my external drive to the computer with no problems.

Yes, Intel PCs have support for thunderbolt since it's a Intel feature. This is a link to Intel's website about thunderbolt 

I don't see anything in the ZTE Blade 10 Prime specifications about thunderbolt. I don't think thunderbolt has anything to do with it but I do see where AMD has a history of USB problems.