Stuck on billing address screen


I'm attempting to get to the esim setup. I have entered all my details on the billing address screen. I click next and the three dots have been bouncing for 20 minutes.


Is there something I'm missing here?



Did you refresh the screen, or try a different browser?


Were you able to resolve this? I'm having the same issue and support is extremely unhelpful. Tried on desktop too but it sends me to the app to complete the process and that's where I get stuck entering the billing address. Tried different accounts and different addresses too. Nothing works. Thank you!


I experienced a similar issue with the billing address page of the Visible App during eSIM setup of a new iphone14 pro (unlocked).


After entering my billing address and hitting next, a message would appear saying Oops.  An error occurred.  Try again later.  Customer Care was unable to resolve the issue after an hour or so spent troubleshooting (reinstalling app, removing eSim from cart and readding, etc).

The following day I performed a power off of the iphone and started it back up.  This time, things went through fine, the problem was gone.  It is uncertain whether restarting the phone fixed the issue, or if they fixed something with their servers prior to me trying again.