Iphone 12 Pro running iOS 17.0.3 unable to send Group Texts

Okay, this may be a longer post, but I want document what I've been dealing with trying to get my group texts working again. This has been going on for a few weeks. 

So I was T-Mobile and the group messaging stopped working after I updated to iOS 17.x. When I would send to a group with at least ONE Android recipient, the thread split apart and each one got a separate text. I use this feature ALOT and so I sought out support.

I worked with Apple Support and T-Mobile and both blamed the other. Apple claimed it was an issue in the account configuration and T-Mobile said it was an issue with the iOS update. I told them that I knew how to test this, that I would get an eSim trial from another provider. Enter Visible. 

I downloaded their trial eSim from visible and without changing a single setting, it worked. Group messaging on my trial eSim (with a trial number) to two friends (one on an iPhone and another on an Android) just worked. 

This proved to me that it was an eSim issue and not phone OS issue. I was happy to switch.  I put in a request to port my number when it ported, group texting was working fine.

About an hour later, I was given a prompt to reboot and I did. When I did, my phone bricked, well sort of. The eSims from T-mobile and the trial eSim from Visible were both gone. I had to find a public Wifi to get a chat going in the App to get support to download a new eSim with my number. I followed all the steps given and my larger group sent out a text and I replied and .... it SPLIT it! BROKEN! WHY?!?!

I've reset my phone's network settings, rebooted, reset my phone and all the other troubleshooting steps. As a former programmer, now an IT Manager, I know about trouble shooting issues. I found another service with trial eSims and downloaded it. It fixed the group texting issue. It does not seem to be a setting issue. I wonder if the "new" eSim I had to download was a different version. The only other factor is the ported phone number itself.

I am likely to rule out the latter though as my number WAS ported and was working for about an hour before the reboot prompt. So that (Visible) eSim was working before it got erased, and the trial eSim from XXXXXX worked too. 

Anyone else want to chime in their thoughts?